You must be logged in to post messages.
Please login or register

Scenario Design and Modding
Moderated by Suppiluliuma, PhatFish, Fisk, EpiC_Anonymous, Epd999

Hop to:    
Welcome! You are not logged in. Please Login or Register.29 replies
Age of Empires Heaven » Forums » Scenario Design and Modding » Fixing 5 Glitched Granary Maps or Scenarios
Bottom
Topic Subject:Fixing 5 Glitched Granary Maps or Scenarios
« Previous Page  1 2  Next Page »
rakovsky
Clubman
posted 08-21-20 07:37 PM ET (US)         
I tried playing 5 maps or scenarios in the Granary that looked good or turned out to be worthwhile on playing them that had a glitch that made them unbeatable. I'd like to see if they can be fixed. 4 of them I can fix myself and submit them myself as "________ Version 2.0". Normally it's best of course for the authors themselves to fix their scenarios, but I tried contacting all the authors and either they hadn't provided their addresses, their addresses no longer worked, or they weren't willing/able to fix it themselves and I'd like to fix it on their behalf. The maps or scenarios are:

#3 Meditteranean Sea 200 BC in the Map Pack [REAL] Maps / "8 real world maps" (http://aoe.heavengames.com/dl-php/showfile.php?fileid=2547)
This is an .SCX file, meaning that it's a Scenario file for R.O.R. When I try to Load the scenario either as a first person scenario for play or in my Scenario Editor, my ROR UPATCH game program crashes. After one such attempt, in order to get my ROR Game Program to even work with other Scenarios, I had to delete this Map/Scenario from my Scenarios folder. I don't know what the problem is, but it seems like a software programmer or someone skilled would have to look at the data in the file to diagnose the problem. I couldn't find any contact information for the map designer, Brainless_AOKH.

Drusus and Tiberius (I beat it in Rise of Rome. I met the Objectives in AOE1.0 but the game didn't end. I submitted a fixed "Version 2" to the Granary.)
(http://aoe.heavengames.com/dl-php/showfile.php?fileid=1723&ci=728f23f58cd1b1f725de6a04c14ee1acYToxOntpOjA7YToyOntpOjA7czoxNDoiU2VhcmNoIFJlc3VsdHMiO2k6MTtzOjM2OiJsaXN0ZXIucGhwP3N0YXJ0PTAmYW1wO3NlYXJjaD1kcnVzdXMiO319)
The Scenario has a faulty trigger that is supposed to give your side reinforcements after a while. Hidden under black fog, an enemy tower on the east side shoots three of your allies' standing elephants and after killing them the tower starts to shoot your lame priest standing nearby, which in turn activates three Gaia horsemen near the priest to join your side.

The trigger has two problems. One is that if you are playing on Easy or Easiest modes, the tower does not shoot your lame priest, so you do not get the reinforcements. And you need the reinforcements to complete an objective, so without them, you cannot win on Easy or the Easiest mode. The second problem that the trigger causes is that, as the designer Richard Ames told me, save games won't work if they have been saved while an arrow is shooting. And the trigger makes it so that the tower is constantly shooting arrows. So you can't save the game, regardless of the difficulty level. The result of all these problems is that you are stuck playing the scenario, which is already a difficult one, on the Moderate-Hardest modes with no saving abilities.


This Scenario must be made for AOE 1.0 because I typically play with 1.0c and I remember having trouble saving. On RockNROR-modded AOE 1.0c:
1. I loaded a savegame from not long after I started up, and got: "Out of Memory, Please Free some memory, then retry." ie. the Savegame was broken.
2. I played a bit, finding different Gaia units, set out for the east dock and saved. Then when I tried to load it, I got: Age of Empires has stopped working. A problem caused the program to stop working correctly. The savegame was broken.
3. This happened a third time, after I made a savegame when I was about to discover the troops in the SW red base.


On regular AOE 1.0, my first save worked from right before I went to the east Gaia dock.

The Readme doesn't specify whether this was made for AOE 1.0, so I would resubmit the scenario using 1.0c and take out the trigger so that you just start with the reinforcements. That way you might avoid the savegame problem with 1.0c and would be able to play on Easy or Easiest, as the trigger only works on Moderate or harder. I thought that probably it was made in the 1.0c version because this scenario came out later on, in 2005. Richard Ames the designer told me that he will have another look at the file, but otherwise I would like to resubmit the file myself with the glitch fixed.

"Roman Expansion into Britannia" Campaign (Scenarios #1 & 3 are glitched in AOE 1.0 & 1.0c but not in ROR. I fixed the glitches and submitted it as Version 2.)
(http://aoe.heavengames.com/dl-php/showfile.php?fileid=861&ci=ce7a7dd69039c82fd09c6be6aa7ce01eYToxOntpOjA7YToyOntpOjA7czoxNDoiU2VhcmNoIFJlc3VsdHMiO2k6MTtzOjM3OiJsaXN0ZXIucGhwP3N0YXJ0PTAmYW1wO3NlYXJjaD1oYWRyaWFuIjt9fQ==)

The Campaign was made in the 1.0 version because this campaign came out in 1998, only about a year after the game itself did, whereas 1.0c came out in 2002.

The Campaign was well designed, but for some reason even when I met the objectives in Scenarios 1 and 3 in AOE, the game does not end. I used the Editor to check the Victory Conditions and they look fine and precise, yet meeting them for some reason does not win the game. I emailed the designer Sean Egan, but the email bounced (picassoj@yahoo.com). I don't know if he is the same as the Google programmer mentioned on Wikipedia by the same name. In any case, I'd like to do-over or streamline the same victory conditions so that they work and then resubmit the campaign file.

The Eagle (I uploaded a fixed version to the Granary as Version 2)
(http://aoe.heavengames.com/dl-php/showfile.php?fileid=2440)
This ROR Scenario has a few glitches or issues. I emailed the designer West Coast Customs (sexygeorgia1997@hotmail.com), but the message bounced. West Coast Customs is now a well known car customizing company founded in 1994 that has worked with Microsoft. I guess that they could be related to the Designer.

One is that the instructions require you to take the war chest from the Brown team in the north back below Hadrian's (your Red Ally's) wall. The obvious way to do this is to bring the chest through the "T" entrance north of your Red Ally's (Rome's) main base. The problem with this is that it's very narrow, only about a wall space wide, so that at any time only one or two infantry can fit width-wise from wall to wall in the "T" entrance. Red soldiers practically always go to stand in the T entrance and not go anywhere, leaving not enough room to bring the chest back through that northern entrance. The only practical way to get them to move is to fight them, and if you try to fight your way through the northern gate your units get creamed, mainly because of the multiple ballista towers there. So the T entrance should really be widened to let the war chest fit through.

A second way to get your war chest back is to chop a path through the forest below the Brown base. If you turn on "reveal map", you can easily see this path south of the main brown base that runs from a clearing south of the brown base down to the western end of the Red Player's walls. To get your ark to the path, you have to chop through the trees. But this path is actually not visible enough to the player due to the black map fog over it. The only way the player would even realise that it's there without using the Reveal Map cheat is by either randomly chopping down tons of forests to see what would happen or else maybe choose for some reason to declare war on Red and break Red's walls to see what would happen.

Looking at the map in the Scenario Editor, it looks like this second route could have been the author's intent, ie. he might have decided to put in a path through the woods here. Plus, if we are basing this on the movie, then the story would basically end after the protagonist captured the relic and defeated the Picts in battle. To make the player bring the relic back on the same circuitous route that he came would be anti-climactic. It looks like the author might have wanted to make a hidden, simpler route back home. So something should be mentioned about the existence of this route in the Hints section. Like the player should be told where to chop down the trees to get to the path or the BMP map should mark this.

However, there is another problem with the second route home: it is blocked by your Red ally's wall. Maybe the map designer thought about adding a gate there but didn't know how to do that in a way that would keep the Player from taking advantage of it when he started and using it as a simple, quick way into the Brown base instead of getting to the Brown base through the eastern long route. The designer could have addressed that problem by adding a victory condition where some units must do something on the eastern long route, or he could have added an instruction that they have to leave by the eastern route. If he wanted to make the second, western path route back an option, he could have put a line of "blue" walls where the Red western wall went that your character could simply delete when he was ready to go back through them.

All in all, it looks like it would be closer to the author's purpose to just widen the eastern "T" entrance to the Roman base instead of fixing the western wall issue.

The third problem (after the ones with the two potential paths mentioned above) is that even if you do succeed in getting your war chest back home, the instructions don't say where exactly to get your chest. The answer, based on what is shown in the scenario Editor, is actually that the Destination Area for the chest is the rectangular area inside Red's main base where the Town Center is located. The instructions should be specific about this.

The fourth glitch (and the only one that is a pure "glitch") is that even if you get the chest to the Destination area, the Scenario does not end. I found this out because I was actually able to get the chest to the victory rectangle by declaring war on the Red team and breaking through the western end of the wall along the second path above. The reason that this happens is that the designer checked "Allied Victory" on the Diplomacy menu. The "Allied Victory" setting imposes a requirement that all of your allies' victory conditions must be met in order for you to win the match. The designer had not set any Individual Victory conditions for your allies, so what that in effect means is that you must defeat all the teams who you are enemies with in order to win. In turn, this means that you must defeat both the Brown and Red teams, because you have to switch the Red team to be your enemy in order to break through their western wall. To fix this glitch, someone must just uncheck "Allied Victory" in the Diplomacy menu in the Scenario Editor.

The fifth problem is that the instructions say that you have an alternative victory strategy whereby instead of bringing home the war chest, all you need to do is wipe out the Brown Player. Specifically, it says, "instead of doing two objectives you can choose Objective 3: Destroy Seal Prince's army and capital (Very Hard)". However, first of all, this is pretty hard due to the enemy's Mirror Towers. You would need a bunch of catapults and monotheist priests to take them down, and the Scenario doesn't give you enough gold to both research monotheism and make many priests, and in fact the siege workshop is disabled from your build menu. But even if you could somehow take down the Brown team, this would not actually give you a Victory. I tried using the Kill4 Command and the game did not end at that point when I did. Plus, when I checked the Victory Conditions in the Scenario Editor, there was nothing about taking down Player 4 (the Brown Player).

Actually, I doubt that there is any way that you could use the Scenario Editor to create an "Alternative" Victory setup whereby the player would EITHER bring a war chest to an area OR Destroy Player 4 to win. More broadly, the Editor doesn't seem capable of setting up alternative independent victory conditions involving the "Individual Victory" menu. For instance, in a "Standard Victory" setting you can win by building a Wonder or defeating all enemies, but if you choose an Individual Victory condition, then the game demands that you meet that Individual condition, whether or not you also chose to impose one of the "Global" Victory conditions.

So when he wrote the instructions, the scenario designer either knew that the Player wouldn't be able to beat AI Player #4 and meet this alternative victory condition and the designer wanted to suggest an unachievable optional challenge, or the designer mistakenly thought that AOE games automatically end when the Human Player wipes out his enemies or that checking "Allied Victory" would automatically give you a victory if you met your allies' victory condition of defeating the Brown team. Probably the last explanation is true and the designer was thinking of the Standard Victory condition where you have an option to either A) capture and hold artifacts that look like the War Chest for a set period of time or B) Destroy all enemies.

[This message has been edited by rakovsky (edited 08-28-2020 @ 09:51 PM).]

AuthorReplies:
rakovsky
Clubman
posted 08-30-20 04:23 PM ET (US)     26 / 29       
I told him that I was submitting Version 2 to the Granary and about your greetings, Fruktfisk. He replied:
Aw thanks - don't really think of myself as an old master, I would reserve that category for the likes of Ingo, Andrea and others
rakovsky
Clubman
posted 09-14-20 09:01 PM ET (US)     27 / 29       
I played "Ctesiphon" by Granite_Rocks/S_Bishop in his Complete Ages of Mankind Campaign (http://aoe.heavengames.com/dl-php/showfile.php?fileid=2628) It has a strange glitch where your Blue Player enemy gets a Victory and defeats you soon after you start to fight him in order to capture the relic in his base. What could cause this?

I checked the VCs for the Scenario and they give the Blue Player if he destroys "Player 2", which would be your Red Player Ally. Your Red Player Ally is weak in this game, but has a Town Center and Barracks and other buildings. I even Tributed 1000 Wood, Gold, and Stone to Red, so he is not low on resources, and he started making a lot of units.

I order to diagnose the problem, I edited the Scenario in my Editor so that I started with 7 juggernauts and a mass of infantry in order to see if the glitch was repeatable. Then when playing my edited version I declared war on Blue, stormed Blue's beach on HARD, and the same thing happened. Somehow Blue got a Victory 2 minutes 50 seconds after I started my "edited" version of the game. Next, I set the difficulty to EASIEST and the same thing happened, so it's not an issue with the Difficulty setting.

The only thing that I can think of is that somehow your Red Player Ally decides to surrender because the AI calculates that the Blue Enemy is far stronger than him. But this does not seem very likely, because in my experience, the AI typically surrenders when you have destroyed practically all his units.

How could you explain this problem?

[This message has been edited by rakovsky (edited 09-14-2020 @ 10:51 PM).]

rakovsky
Clubman
posted 09-17-20 12:12 PM ET (US)     28 / 29       
I made a new thread to address your comments on the Battle for the Ark Scenario:
https://aoe.heavengames.com/cgi-bin/aoecgi/display.cgi?action=ct&f=4,6672,,10

[This message has been edited by rakovsky (edited 09-17-2020 @ 01:03 PM).]

rakovsky
Clubman
posted 11-02-20 04:47 PM ET (US)     29 / 29       
I submitted a Sixth Scenario for my series on Early Christianity called the Killing of Nero.

Also, when I played online and asked people to install the Real Maps pack, I kept having to explain to them about deleting File "#3 Meditteranean Sea" because when people extract the maps from that map pack to their Scenario folder, their whole game will not work.

As a result, I deleted Map #3, the corrupt map file, from the map pack and submitted it as "Version 2."
« Previous Page  1 2  Next Page »
You must be logged in to post messages.
Please login or register

Hop to:    

Age of Empires Heaven | HeavenGames