You must be logged in to post messages.
Please login or register

Age of Empires / Rise of Rome / Definitive Edition
Moderated by Suppiluliuma, PhatFish, Fisk, EpiC_Anonymous, Epd999

Hop to:    
Welcome! You are not logged in. Please Login or Register.5 replies
Age of Empires Heaven » Forums » Age of Empires / Rise of Rome / Definitive Edition » "Dawn of Civilization" demo campaign - AI issues playing it on full version
Bottom
Topic Subject:"Dawn of Civilization" demo campaign - AI issues playing it on full version
Romanos_V
Clubman
posted 03-25-18 08:47 AM ET (US)         
Background:
Thanks to the contributor who recently added the "Dawn of Civilization" campaign to the "Campaigns in Age of Empires" Box within the AoW Wiki, I learned of that campaign. Of course, I downloaded it from the Granary (link)
Scenarios 1-3 are unspectacular due missing enemies' economy. But its nice to explore the history of AoE development. Needless to say that all the demo exclusive campaigns are pretty nice.

Note:
Otherwise than stated in the wiki, the scenarios 1-4 are not identical to scenarios of the Egyptian learning campaign.

Issue:
When playing scenarios 4 and 5 the AI does not build an economy at all!
Scenario 4:
The starting villagers are used to explore and to gather some food. The yellow player pumps watchtowers. Both players do not train even one villager. Soon their economies lie almost entirely idle.
Scenario 5: also no villager production.

Summarizing, both scenarios are ridiculously easy at the lastest when the attacks of starting military units are repelled. That cannot be intentional.

My suspicion:
In the full version the game loads a wrong ai script. Most likely there was a different script with the same name in the CGW demo, and now the scpript loaded ist unsuitable for proper playing. Or there are some required scripts missing in the full version.

What I have done so far:
I tested in in AoE 1.0c and RoR UPatch HD R4
Tested it on moderate and hardest difficulty

If one wants to transfer the demo campaigns to the full versions, some ai files have to be transferred either or the game crashes otherwise. Yet this is not the case here.

My request:
How to fix that?
AuthorReplies:
PhatFish
Mr. Beta
posted 03-31-18 04:14 AM ET (US)     1 / 5       
I've never heard of a scenaruo crashing due to missing AI or PER files. In any case you would need the original files or create your own from scratch (which shouldn't be too difficult).



Romanos_V
Clubman
posted 04-04-18 01:57 PM ET (US)     2 / 5       
PhatFish
Mr. Beta
posted 04-04-18 02:44 PM ET (US)     3 / 5       
You should instead play the full CGW demo if you want things to work more properly I guess.



av29
Clubman
posted 04-18-18 05:41 PM ET (US)     4 / 5       
I'm the contributor that made it. Feel free to edit the AoE and make changes to reflect better the information.
Romanos_V
Clubman
posted 05-22-18 04:59 AM ET (US)     5 / 5       
@av29: Thank you for adding that CGW campaign to the wiki. I'll try to expand it on this topic.

@PhatFish: I literally copied all the .ai and .per files from the demo to all the ai, data, and data2 folders and the problem still remains.

Of course one could install the demo. But first it is 16 bit so running it on Win10 is impossible without massive and annoying effort. And secondly my aim is to include it properly on RoR with UPatch HD, as the author of latter one did with the other demo campaigns.

Right now I am trying to reconstruct the AI by using .ai and .per files which are included in a clean RoR + UPatch HD installation.

Maybe one day I will upload a package containing the original .cpn file, a fixed version as .cpx and the demo random map scenario ("Battle_1.scn") which is also included in the CGW Demo.
You must be logged in to post messages.
Please login or register

Hop to:    

Age of Empires Heaven | HeavenGames