You must be logged in to post messages.
Please login or register

Age of Empires / Rise of Rome / Definitive Edition
Moderated by Suppiluliuma, PhatFish, Fisk, EpiC_Anonymous, Epd999

Hop to:    
Welcome! You are not logged in. Please Login or Register.6 replies
Age of Empires Heaven » Forums » Age of Empires / Rise of Rome / Definitive Edition » Is there a patch for DirectDraw incompatibility problems?
Bottom
Topic Subject:Is there a patch for DirectDraw incompatibility problems?
Gubbubu
Clubman
posted 03-12-10 12:18 PM ET (US)         
AoE games and Star Wars Galactic Battlegrounds don't run since I changed my computer from a PCI-based mainboard and a museal S3 Virge Graphic Card to a Gygabyte board and an ATI Radeon graphic card. They terminate with the error message 'Could not initialize graphic system. Make sure your video card is compatible with direct draw.'

As I see searching the web for troubleshouting, many other people have the same problem, and more and more will meet it as hardware and software developments make older games out of date. My distributor said that my videocard is not compatible with those old DirectX and DirectDraw versions required for Genie engine based games, and the problem cannot be fixed, unless Microsoft (or Lucasarts) writes a patch to fix it (we must admit it, the latter is quite improbable).

Is there a simple and comfortable way to solve this problem?
Or must we start to affiliate with the thought Genie games soon would disappear (slowly, but surely) like DOS games?

Thx for any substantive remarks;
G.

[This message has been edited by Gubbubu (edited 03-12-2010 @ 12:26 PM).]

AuthorReplies:
Suppiluliuma
AoEH Seraph
posted 03-14-10 07:50 PM ET (US)     1 / 6       
Ow, this isn't good at all. The more powerful video cards would make some of our fave games unplayable and it sucks. I hope someone has a solution for this, because i doubt both M$ or LucasArts care anymore about the older AoE or GB gamers .

Thanks for the info tho Gubbubu.
DeSirE
Clubman
posted 03-14-10 11:06 PM ET (US)     2 / 6       
Hey guys {ps look whose posts make up this thread, the two guys with some of the hardest to pronounce names in all of AoEH... I said Gubbubu in my head a few times to get it right, its catchy!
As for Suppiluliuma, im still not sure if im saying THAT right... }

Reducing the "hardware acceleration" on your graphics card might solve the problem.

Heres the steps: http://www.pptfaq.com/FAQ00129.htm

If that didnt fix it, have you tried updating your gfx. card to the latest drivers?

If that didnt fix it, have you tried unplugging your monitor from your graphics card and plugging it into your onboard/integrated graphics card on the motherboard (basically if theres 2 plugs that can fit the monitor plug, the one closer to the bottom is your graphics card and the one higher is your motherboard)

If that works then great..

Have you tried running AoE in "windows 95 compatibility mode" ?

Let us know how it goes, Gubbubu {proceeds to say name in head another 3 times }
Gubbubu
Clubman
posted 03-15-10 08:34 AM ET (US)     3 / 6       
Thx to Suppiluliuma and DeSirE for remarks.

First, I have to note our nick names are so strange because of ancient (semitic/sumerian) origins. In Age of Empires I. you can see similar strange stuff. Gubbubu is a sumerian name and its radix probably means "to burn / to fry". Suppiluliuma, in turn, was an accadian hittite king (or something similar).


Second, I've tried your ideas but unfortunately, none worked. So my problem is open yet.

G.

[This message has been edited by Gubbubu (edited 03-15-2010 @ 08:36 AM).]

robjm88
Clubman
posted 03-26-10 11:36 AM ET (US)     4 / 6       
I was reading online and some people have suggested that it could be related to your directx version, which would be updated with your new card... if thats the case, you could get a second(older) card and install that. Running two cards might fix the issue? Not sure... Or dual boot your pc...?
Gubbubu
Clubman
posted 04-05-10 06:00 AM ET (US)     5 / 6       
Since I've posted my problem here, one of my friends found a solution for running the game. He deleted my video card's setup and reinstalled its driver from the ATI homepage (the main idea of him was that not to allow to work all programs on the Video Card Setup CD but the driver only, and he seems to be right).

But despite of this I'm not satisfied. Using some of the game functions, for example "diplomacy" and "chat", causes all Genie (AoE, AoE RoR, AoE II. and SWGB) games to crash with a black screen. So this solution is not 100% good :-(.

Maybe dual boot will be a solution ... I hope.
Suppiluliuma
AoEH Seraph
posted 04-06-10 08:28 PM ET (US)     6 / 6       
Thanks for keeping us posted of any progress Gubbubu! so you say it is possible for them to work except when some functions are opened?
You must be logged in to post messages.
Please login or register

Hop to:    

Age of Empires Heaven | HeavenGames